OpenRoads Designer CONNECT Edition SDK Help

ExtendEndByLineOrTrim(Double, Double) Method

Returns extended by line or trimmed element from its end point

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public  LinearElement ExtendEndByLineOrTrim(double extTrimLength,double ptToPtTolerance)

Parameters

SettingDescription
   Length to trim or extend
   Point to point tolerance used to perform the operation.

Return Value

LinearElement Extended or trimmed element

See Also